C++编程:题目挺容易的,但老是超时,求大神帮我看看,感激不尽

题目:SubmitStatisticNextProblemProblemDescriptionValerahadtwobagsofpotatoes,thefirstoft... 题目:
Submit StatisticNext Problem
Problem Description
Valera had two bags of potatoes, the first of these bags contains x (x ≥ 1)potatoes, and the second — y (y ≥ 1) potatoes. Valera — very scattered boy, so the first bag of potatoes (it contains x potatoes) Valera lost. Valera remembers that the total amount of potatoes (x + y)in the two bags, firstly, was not gerater than n, and, secondly, was divisible by k.Help Valera to determine how many potatoes could be in the first bag. Print all such possible numbers in ascending order.
Input
The first line of input contains three integers y, k, n (1 ≤ y, k, n ≤ 109; n/k  ≤ 105).
Output
Print the list of whitespace-separated integers — all possible values of x in ascending order. You should print each possible value of x exactly once.If there are no such values of x print a single integer -1.
Sample Input
10 1 1010 6 40

Sample Output
-12 8 14 20 26
展开
 我来答
百度网友f160a72
2013-04-26 · TA获得超过363个赞
知道小有建树答主
回答量:461
采纳率:0%
帮助的人:396万
展开全部
#include <iostream>
using namespace std;

int main(){
int y, k, n, x;
int i;
while(cin>>y>>k>>n){
i = y / k + 1;
x = 0;
for(; x + y <= n - k; i++){
x = k*i - y;
cout<<x<<" ";
}
if(i == (y/k + 1)) cout<<-1;
cout<<endl;
}
}
追问
程序错了,最后好像多输出了一个空格吧,麻烦你再看看
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
dream龙魄
2013-04-27
知道答主
回答量:21
采纳率:0%
帮助的人:22万
展开全部
#include <iostream>
using namespace std;

int main(){
int y, k, n, x;
int i;
while(cin>>y>>k>>n){
i = y / k + 1;
x = 0;
for(; x + y <= n - k; i++){
x =.
本回答被提问者采纳
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式