C++编程:题目挺容易的,但老是超时,求大神帮我看看,感激不尽
题目:SubmitStatisticNextProblemProblemDescriptionValerahadtwobagsofpotatoes,thefirstoft...
题目:
Submit StatisticNext Problem
Problem Description
Valera had two bags of potatoes, the first of these bags contains x (x ≥ 1)potatoes, and the second — y (y ≥ 1) potatoes. Valera — very scattered boy, so the first bag of potatoes (it contains x potatoes) Valera lost. Valera remembers that the total amount of potatoes (x + y)in the two bags, firstly, was not gerater than n, and, secondly, was divisible by k.Help Valera to determine how many potatoes could be in the first bag. Print all such possible numbers in ascending order.
Input
The first line of input contains three integers y, k, n (1 ≤ y, k, n ≤ 109; n/k ≤ 105).
Output
Print the list of whitespace-separated integers — all possible values of x in ascending order. You should print each possible value of x exactly once.If there are no such values of x print a single integer -1.
Sample Input
10 1 1010 6 40
Sample Output
-12 8 14 20 26 展开
Submit StatisticNext Problem
Problem Description
Valera had two bags of potatoes, the first of these bags contains x (x ≥ 1)potatoes, and the second — y (y ≥ 1) potatoes. Valera — very scattered boy, so the first bag of potatoes (it contains x potatoes) Valera lost. Valera remembers that the total amount of potatoes (x + y)in the two bags, firstly, was not gerater than n, and, secondly, was divisible by k.Help Valera to determine how many potatoes could be in the first bag. Print all such possible numbers in ascending order.
Input
The first line of input contains three integers y, k, n (1 ≤ y, k, n ≤ 109; n/k ≤ 105).
Output
Print the list of whitespace-separated integers — all possible values of x in ascending order. You should print each possible value of x exactly once.If there are no such values of x print a single integer -1.
Sample Input
10 1 1010 6 40
Sample Output
-12 8 14 20 26 展开
2个回答
展开全部
#include <iostream>
using namespace std;
int main(){
int y, k, n, x;
int i;
while(cin>>y>>k>>n){
i = y / k + 1;
x = 0;
for(; x + y <= n - k; i++){
x = k*i - y;
cout<<x<<" ";
}
if(i == (y/k + 1)) cout<<-1;
cout<<endl;
}
}
using namespace std;
int main(){
int y, k, n, x;
int i;
while(cin>>y>>k>>n){
i = y / k + 1;
x = 0;
for(; x + y <= n - k; i++){
x = k*i - y;
cout<<x<<" ";
}
if(i == (y/k + 1)) cout<<-1;
cout<<endl;
}
}
追问
程序错了,最后好像多输出了一个空格吧,麻烦你再看看
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询