用C语言编译程序:输入制定年月的月份天数
要求:输入1900-3000年之间的某个日期y年m月,求出y年m月有多少天。若要结束输入则输入y或Y,否则,继续输入年、月,输出当月的天数。输入年份y和月份m输出y年M月...
要求:输入1900-3000年之间的某个日期y年m月,求出y年m月有多少天。
若要结束输入则输入y或Y,否则,继续输入年、月,输出当月的天数。
输入
年份y和月份m
输出
y年M月应有的天数d
样例输入
1998 2
n
2000 5
y
样例输出
28
31
提示:
注意闰年的判断。
希望有高手能帮忙,不胜感谢!!! 展开
若要结束输入则输入y或Y,否则,继续输入年、月,输出当月的天数。
输入
年份y和月份m
输出
y年M月应有的天数d
样例输入
1998 2
n
2000 5
y
样例输出
28
31
提示:
注意闰年的判断。
希望有高手能帮忙,不胜感谢!!! 展开
2个回答
展开全部
#include <stdio.h>
#include <stdlib.h>
void print_day(int year, int month)
{
switch (month)
{
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
printf("31\n");
break;
case 4:
case 6:
case 9:
case 11:
printf("30\n");
break;
case 2:
if ((0 == year % 400) || ((0 == year % 4) && (0 != year % 100)))
{
printf("29\n");
}
else
{
printf("28\n");
}
break;
default:
printf("month error!\n");
break;
}
}
int main(int argc, char **argv)
{
setbuf(stdout, NULL);
int year = 0, month = 0;
char ch;
do
{
printf("enter year and month:");
scanf("%d %d", &year, &month);
//scanf()在接收完输入后会有一个enter字符留在缓冲区,
//getchar()是用来接收enter字符的,否则将会影响下一个字符的输入
getchar();
print_day(year, month);
printf("conitue?");
scanf("%c", &ch);
} while ('y' == ch || 'Y' == ch);
return EXIT_SUCCESS;
}
#include <stdlib.h>
void print_day(int year, int month)
{
switch (month)
{
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
printf("31\n");
break;
case 4:
case 6:
case 9:
case 11:
printf("30\n");
break;
case 2:
if ((0 == year % 400) || ((0 == year % 4) && (0 != year % 100)))
{
printf("29\n");
}
else
{
printf("28\n");
}
break;
default:
printf("month error!\n");
break;
}
}
int main(int argc, char **argv)
{
setbuf(stdout, NULL);
int year = 0, month = 0;
char ch;
do
{
printf("enter year and month:");
scanf("%d %d", &year, &month);
//scanf()在接收完输入后会有一个enter字符留在缓冲区,
//getchar()是用来接收enter字符的,否则将会影响下一个字符的输入
getchar();
print_day(year, month);
printf("conitue?");
scanf("%c", &ch);
} while ('y' == ch || 'Y' == ch);
return EXIT_SUCCESS;
}
本回答被提问者采纳
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询