北大ACM第1006,我用C语言写的,调试时都是成功的为什么提交时出现Wrong Answer;请各位C语言大虾们看看
Description人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表...
Description
人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。
Input
输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。
当p = e = i = d = -1时,输入数据结束。
Output
从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。
采用以下格式:
Case 1: the next triple peak occurs in 1234 days.
注意:即使结果是1天,也使用复数形式“days”。
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
我的代码是:
#include<stdio.h>
int f(int p,int e,int i,int d)
{
int m,s,t,j;
for(j=1;j<=924;j++)
{
m=p+23*j;
s=(m-e)/28;
t=(m-i)/33;
s=s*28+e;
t=t*33+i;
if(m==s&&m==t)
{
if(m>=21252)
return 21252-d;
if(d<m)
return m-d;
return d-m;
}
}
}
int main()
{
int a[10000],j=0,k;
int p,e,i,d;
scanf("%d%d%d%d",&p,&e,&i,&d);
while(p>=0&&p<=365&&e>=0&&e<=365&&i>=0&&i<=365&&d>=0&&d<=365)
{
a[j++]=f(p,e,i,d);
scanf("%d%d%d%d",&p,&e,&i,&d);
}
for(k=0;k<j;k++)
printf("Case %d: the next triple peak occurs in %d days.\n",k+1,a[k]);
return 0;
}
我不清楚我的代码在哪里出错了,请各位C语言大侠们帮忙看看……谢啦哈O(∩_∩)O~ 展开
人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。
Input
输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。
当p = e = i = d = -1时,输入数据结束。
Output
从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。
采用以下格式:
Case 1: the next triple peak occurs in 1234 days.
注意:即使结果是1天,也使用复数形式“days”。
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
我的代码是:
#include<stdio.h>
int f(int p,int e,int i,int d)
{
int m,s,t,j;
for(j=1;j<=924;j++)
{
m=p+23*j;
s=(m-e)/28;
t=(m-i)/33;
s=s*28+e;
t=t*33+i;
if(m==s&&m==t)
{
if(m>=21252)
return 21252-d;
if(d<m)
return m-d;
return d-m;
}
}
}
int main()
{
int a[10000],j=0,k;
int p,e,i,d;
scanf("%d%d%d%d",&p,&e,&i,&d);
while(p>=0&&p<=365&&e>=0&&e<=365&&i>=0&&i<=365&&d>=0&&d<=365)
{
a[j++]=f(p,e,i,d);
scanf("%d%d%d%d",&p,&e,&i,&d);
}
for(k=0;k<j;k++)
printf("Case %d: the next triple peak occurs in %d days.\n",k+1,a[k]);
return 0;
}
我不清楚我的代码在哪里出错了,请各位C语言大侠们帮忙看看……谢啦哈O(∩_∩)O~ 展开
1个回答
展开全部
显然是
if(m>=21252)
return 21252-d;
这个地方有问题。 他只是说最终所求天数是小于21252的。不是说m >= 21252就按照21252来计算。
另外:
1、判断p是否能整除28、33最方便的方式是求模:
if( ((m - e) % 28 == 0) && ((m - p) % 33 == 0))
2、循环的时候显然用33这个最大的数,才能保证循环的次数尽可能的小;
下面是很久以前写的一个:
int get_days(int p , int e ,int r , int d) {
int res = r + 33;
while(! (((res - e) % 28 ==0) && (res - p) % 23 ==0)) {
res += 33;
}
res -= d;
while(res > 0) {
res -= 21252;
}
while(res <= 0) {
res += 21252;
}
return res;
}
仅供参考^_^
if(m>=21252)
return 21252-d;
这个地方有问题。 他只是说最终所求天数是小于21252的。不是说m >= 21252就按照21252来计算。
另外:
1、判断p是否能整除28、33最方便的方式是求模:
if( ((m - e) % 28 == 0) && ((m - p) % 33 == 0))
2、循环的时候显然用33这个最大的数,才能保证循环的次数尽可能的小;
下面是很久以前写的一个:
int get_days(int p , int e ,int r , int d) {
int res = r + 33;
while(! (((res - e) % 28 ==0) && (res - p) % 23 ==0)) {
res += 33;
}
res -= d;
while(res > 0) {
res -= 21252;
}
while(res <= 0) {
res += 21252;
}
return res;
}
仅供参考^_^
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询