谁帮我编几道题啊 用C++语言 谢谢了

MrSomurolov,fabulouschess-gamerindeed,assertsthatnooneelsebuthimcanmoveknightsfromone... Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?

The Problem

Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.

For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input
The input begins with the number n of scenarios on a single line by itself.

Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 ≤ l ≤ 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0
我明天需要交 麻烦高手了 高手的话 2分钟就ok了 谢了
展开
 我来答
qyjubriskxp
2010-08-30 · TA获得超过892个赞
知道小有建树答主
回答量:735
采纳率:0%
帮助的人:737万
展开全部
最容易想到的方法是bfs
#include <queue>
#include <iostream>
using namespace std;
#define INGRID(x,y) (x>=0&&x<size&&y>=0&&y<size)
bool arrived[300][300];
const int INF=1<<30;
const int dir[8][2]={{2,1},{1,2},{-1,2},{-2,1},{-2,-1},{-1,-2},{1,-2},{2,-1}};
class point
{
public:
point(){}
point(int x,int y,int depth):x(x),y(y),depth(depth){}
int x;
int y;
int depth;
};
int main()
{
int n;
cin>>n;
while(n--)
{
int size;
point start(0,0,0),end;
bool flag=false;
cin>>size>>start.x>>start.y>>end.x>>end.y;
if(start.x==end.x&&start.y==end.y)
{
cout<<0<<endl;
continue;
}
for(int i=0;i<size;i++)for(int j=0;j<size;j++)arrived[i][j]=false;
queue<point> q;
q.push(start);
while(q.size()!=0)
{
point p=q.front();
q.pop();
for(int i=0;i<8;i++)
{
int tarx=p.x+dir[i][0],tary=p.y+dir[i][1];
if(!INGRID(tarx,tary))continue;
if(arrived[tary][tarx])continue;
if(end.x==tarx&&end.y==tary)
{
flag=true;
cout<<p.depth+1<<endl;
break;
}
q.push(point(tarx,tary,p.depth+1));
arrived[tary][tarx]=true;
}
if(flag)break;
}
}
return 0;
}
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式