求C语言程序:计算两点间的距离
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
输入描述
输入数据由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
输出描述
对于输入数据,输出一行,结果保留两位小数。
输入样例
1 2 2 3
输出样例
1.41 展开
代码如下:
#include<stdio.h>
#include<math.h>
struct point
{
double x;
double y;
};
struct point readPoint();
double distance(struct point p1,struct point p2);
int main(void)
{
struct point a,b;
double dis;
printf("\n distance! \n\n");
printf("please input the point(for example:1.0,2.0):");
a=readPoint();
printf("\nplease input the point(for example:1.0,2.0):");
b=readPoint();
dis=distance(a,b);
printf("\nthe distance is:%.2f\n",dis);
return 0;
}
struct point readPoint()
{
struct point p;
scanf("%lf,%lf",&p.x,&p.y);
return p;
}
double distance(struct point p1,struct point p2)
{
double d;
d=sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
return d;
}
C语言是一种计算机程序设计语言,它既具有高级语言的特点,又具有汇编语言的特点。它由美国贝尔研究所的D.M.Ritchie于1972年推出,1978年后,C语言已先后被移植到大、中、小及微型机上,它可以作为工作系统设计语言,编写系统应用程序,也可以作为应用程序设计语言,编写不依赖计算机硬件的应用程序。
它的应用范围广泛,具备很强的数据处理能力,不仅仅是在软件开发上,而且各类科研都需要用到C语言,适于编写系统软件,三维,二维图形和动画,具体应用比如单片机以及嵌入式系统开发。
#include<stdio.h>
#include<math.h>
int main(){
float x1,y1,x2,y2;
scanf("%f%f%f%f",&x1,&y1,&x2,&y2);
float d = sqrt(pow((x1-x2),2)+pow((y1-y2),2));//sqrt开方,pow次方
printf("%.2f",d);
return 0;
}