c语言编程sum problem

ProblemDescriptionHey,welcometoHDOJ(HangzhouDianziUniversityOnlineJudge).Inthisproble... Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050
展开
 我来答
wmn318
2010-09-10 · TA获得超过201个赞
知道小有建树答主
回答量:188
采纳率:0%
帮助的人:191万
展开全部
#include<stdio.h>
void main()
{
int i,j,n,sum=0;
printf("输入计算组数i: ");
scanf("%d",&i);
printf("\n");
while(i--)
{
scanf("%d",&n);
for(j=1;j<=n;j++)
{
sum+=j;
}
printf("%d\n",sum);
}
}
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式