这道java编程题怎么做?
输入一个字符,判断它如果是小写字母输出其对应的大写字母,如果是大写字符输出其对应的小写字母,如果是数字则直接输出数字,不是上述情况输出other。输入输入只有一组数据,共...
输入一个字符,判断它如果是小写字母输出其对应的大写字母,如果是大写字符输出其对应的小写字母 ,如果是数字则直接输出数字,不是上述情况输出other。
输入
输入只有一组数据,共4行,每一行输入一个字符。
输出
共4行,在每行上针对输入的字符,显示处理后的结果。
难度
一般
输入示例
a
C
1
*
输出示例
A
c
1
other 展开
输入
输入只有一组数据,共4行,每一行输入一个字符。
输出
共4行,在每行上针对输入的字符,显示处理后的结果。
难度
一般
输入示例
a
C
1
*
输出示例
A
c
1
other 展开
1个回答
2020-03-04
展开全部
import java.util.*;
class Test1{
public LinkedList res=new LinkedList();
public Scanner item=new Scanner(System.in);
}
class Test2 extends Test1{
private void calc(){
System.out.println("输入4个字符");
for(int x=0;x<4;x++){
char tem=item.next().charAt(0);
if(Character.isUpperCase(tem)){
tem=Character.toLowerCase(tem);
res.add(tem);
}else if(Character.isLowerCase(tem)){
tem=Character.toUpperCase(tem);
res.add(tem);
}else if(Character.isDigit(tem)){
res.add(tem);
}else{
String str="other";
res.add(str);
}
}
for(Object y:res){
System.out.println(y);
}
}
public static void main(String[] args){
new Test2().calc();
}
}
class Test1{
public LinkedList res=new LinkedList();
public Scanner item=new Scanner(System.in);
}
class Test2 extends Test1{
private void calc(){
System.out.println("输入4个字符");
for(int x=0;x<4;x++){
char tem=item.next().charAt(0);
if(Character.isUpperCase(tem)){
tem=Character.toLowerCase(tem);
res.add(tem);
}else if(Character.isLowerCase(tem)){
tem=Character.toUpperCase(tem);
res.add(tem);
}else if(Character.isDigit(tem)){
res.add(tem);
}else{
String str="other";
res.add(str);
}
}
for(Object y:res){
System.out.println(y);
}
}
public static void main(String[] args){
new Test2().calc();
}
}
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询