有关ACM算法的一道题,请各位大牛帮帮忙!!!

Problem-A+BforInput-OutputDescriptionYourtaskistocalculatethesumofsomeintegers.InputI... Problem - A+B for Input-Output

DescriptionYour task is to calculate the sum of some integers.InputInput contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

OutputFor each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input4 1 2 3 4
5 1 2 3 4 5Sample Output10
15
这是题目,我的代码是:
#include <stdio.h>
#include <stdlib.h>

int main()
{
int i,a,b,sum;
scanf("%d",&a);
sum=0;
for(i=0;i<a;i++) {
scanf(" %d",&b);
sum+=b;
}
printf("%d\n",sum);
return 0;
}
提交后显示超时,1036ms,为什么会这样,希望能有大牛帮忙解答
展开
 我来答
智趣派
2010-12-08 · TA获得超过3116个赞
知道小有建树答主
回答量:729
采纳率:100%
帮助的人:996万
展开全部
这道题属于多组数据输入的,而你的程序只能接受一组数据。
改成这样试试:
#include <stdio.h>
#include <stdlib.h>

int main()
{
int i,a,b,sum;
while(scanf("%d",&a) != EOF){
sum=0;
for(i=0;i<a;i++) {
scanf(" %d",&b);
sum+=b;
}
printf("%d\n",sum);
}
return 0;
}
xal090640224
2010-12-08 · TA获得超过321个赞
知道小有建树答主
回答量:83
采纳率:0%
帮助的人:40.3万
展开全部
while(scanf("%d",&a)!=EOF)程序需要可以输入多组数据的啊,不是算法的问题,而是代码不符合要求 我的回答多余了 呵呵
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
sfwtoms
2010-12-08 · TA获得超过231个赞
知道答主
回答量:41
采纳率:0%
帮助的人:23.8万
展开全部
这个应该是杭电的一道ACM题目 超时是你没有注意到多组数据的输入,基于楼上的给你介绍了代码,我给你介绍下基本的ACM输入模式:
一般题目没有说明就是默认读到EOF就结束 既采用这个模式while(scanf("%d",&input)!=EOF);
还有就是说明给多少组测试数据 这个一般采用
while(n--){
/*处理数据*/
}
还有一种就是尾部有终止符之类的,以0为终止符, 你可以采用这个模式:
while(1)
{ scanf("%d",&ipnut);
if(input==0)break;
else
{
}
}
}
一般ACM的题目都是这三种模式之一 如果遇到其他特殊 可以和我联系
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
收起 更多回答(1)
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式