一道杭电ACM的测试题,我运行的没问题,但是提交却是WA,麻烦大家帮我看一下

ProblemDescriptionJackandJillhavedecidedtosellsomeoftheirCompactDiscs,whiletheystillh... Problem Description
Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input
The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.
Output
For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.
Sample Input
3 3
1
2
3
1
2
4
0 0
Sample Output
2
展开
百度网友c19c0d0
2011-02-01 · TA获得超过1537个赞
知道小有建树答主
回答量:464
采纳率:0%
帮助的人:446万
展开全部
。。。。这不是半程测试的。。
我AC了。。马上给你敲代码。。
敲好了。
用G++提交。。
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[2000008];
int main()
{
int n,m;
int i;
int count;
while(scanf("%d%d",&n,&m),n||m)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(;i<n+m;i++)
scanf("%d",&a[i]);
sort(a,a+n+m);
count=0;
for(i=1;i<n+m;i++)
if(a[i]==a[i-1])
count++;
printf("%d\n",count);
}
return 0;
}
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式