求助c语言的a+b问题

这是问题:ProblemDescriptionCalculatea+b.InputTheinputwillconsistofaseriesofpairsofinteger... 这是问题:
Problem Description

Calculate a + b.
Input

The input will consist of a series of pairs of integers a and b,separated by a space, one pair of integers per line.
Output

For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.
Sample Input

1 5
2 3
Sample Output

6
5
Source

FOJ1000
这是我写的:
#include<stdio.h>
void main()
{
int a,b;
scanf("%d %d",&a,&b);
printf("%d\n",a+b);
}
为什么我在vc6里测试答案是对的,但提交上去不对?
展开
 我来答
皇神创世
推荐于2017-11-24 · TA获得超过903个赞
知道小有建树答主
回答量:937
采纳率:0%
帮助的人:644万
展开全部
The input will consist of a series of pairs of integers a and b,separated by a space, one pair of integers per line.
他要你的程序能够一次输入很多对整数,每行一对,算出来之后,再每行一个结果显示出来,你的程序只处理一对数字
aaasuper
2011-03-08 · TA获得超过801个赞
知道小有建树答主
回答量:431
采纳率:100%
帮助的人:626万
展开全部
#include<stdio.h>
void main()
{
int a,b;
scanf("%d%d",&a,&b);
while(a||b)
{
printf("%d\n",a+b);
scanf("%d%d",&a,&b);
}
}
注意SCANF的两个%d之间没有空格
while循环实现处理多组数据,有不明白的可以继续问
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
zzyhuda
2011-03-08 · TA获得超过611个赞
知道小有建树答主
回答量:503
采纳率:100%
帮助的人:334万
展开全部
英语不好就不要这么牛逼,还看英文教材,哥也没看懂题目是啥,幸亏楼上知道,晕死
#include<stdio.h>
void main()
{
int n,a[100],b[100];
printf("how many pairs of num do you want to enter:");
scanf("%d",&n);
printf("please enter:\n");
for(int i=0;i<n;i++)
scanf("%d %d",&a[i],&b[i]);
printf("\nthe result:\n");
for(int k=0;k<n;k++)
printf("%d+%d=%d\n",a[k],b[k],a[k]+b[k]);
}
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
slkngfalk
2011-03-18
知道答主
回答量:13
采纳率:0%
帮助的人:0
展开全部
支持aaasuper,没问题。。
你的答案应该是用程序来检测吧,zzyhuda的太人性化了哈~~
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
收起 1条折叠回答
收起 更多回答(2)
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式