大家帮帮忙呀!!一道C语言题:A+B for Input-Output Practice (III)

题目描述YourtaskistoCalculatea+b.输入Inputcontainsmultipletestcases.Eachtestcasecontainsapa... 题目描述
Your task is to Calculate a + b.

输入
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

输出
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入
1 5
10 20
0 0

样例输出
6
30
展开
 我来答
iwtku
2011-04-17 · TA获得超过102个赞
知道答主
回答量:62
采纳率:0%
帮助的人:34.9万
展开全部
#include <stdio.h>
main()
{
int a[100];
int b[100];
int c[100];
int i=0,j=0,k=0;
printf("请输入多个a与b的值,若无则输0 0\n");
scanf("%d %d",a,b);
c[0]=a[0]+b[0];
for(;c[k]!=0;)
{scanf("%d %d",&a[++i],&b[++j]);
c[++k]=a[i]+b[j];}
for(k=0;c[k]!=0;k++)
printf("a+b=%d\n",c[k]);
printf("感谢使用本系统!\n");
}

给你个建议,以后最好不要发英文,一般人懒得看的……
追问
额……我也懒得看实际上~~
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
百度网友411022f
2011-04-17
知道答主
回答量:1
采纳率:0%
帮助的人:0
展开全部
#include <stdio.h>

int main()
{
int a,b ;
while(scanf("%d %d",&a,&b))
{
if (a==0&&b==0) break;
printf("%d\n",a+b);
}
return 0;
}
本回答被提问者采纳
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式