杭电acm 1097T 这个代码为什么错误?
InputTherearemutipletestcases.Eachtestcasesconsistsoftwonumbersaandb(0<a,b<=2^30)Outp...
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800
Sample Output
9
6
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{
int c=1,e;
e=b%4;
for(i=1;i<=e+4;i++)
{
m=a*c;
c=m%10;
m=c*a;
}
cout<<c<<endl;
}
return 0;
}
不要其他程序!!只要为什么是错误答案!? 展开
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800
Sample Output
9
6
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{
int c=1,e;
e=b%4;
for(i=1;i<=e+4;i++)
{
m=a*c;
c=m%10;
m=c*a;
}
cout<<c<<endl;
}
return 0;
}
不要其他程序!!只要为什么是错误答案!? 展开
2个回答
展开全部
//改成这样应该可以~
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{
int c=1;
a=a%10;
for(i=0;i<=(b-1)%4;i++)
{
c*=a
}
cout<<c%10<<endl;
}
return 0;
}
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{
int c=1;
a=a%10;
for(i=0;i<=(b-1)%4;i++)
{
c*=a
}
cout<<c%10<<endl;
}
return 0;
}
追问
我问我写的为什么不行???错误在哪??谢谢!!
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询