杭电acm 1097T 这个代码为什么错误?

InputTherearemutipletestcases.Eachtestcasesconsistsoftwonumbersaandb(0<a,b<=2^30)Outp... Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output
For each test case, you should output the a^b's last digit number.

Sample Input
7 66
8 800

Sample Output
9
6

#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{

int c=1,e;
e=b%4;
for(i=1;i<=e+4;i++)
{
m=a*c;
c=m%10;
m=c*a;
}
cout<<c<<endl;

}
return 0;
}
不要其他程序!!只要为什么是错误答案!?
展开
 我来答
304467594
2011-04-23 · 超过14用户采纳过TA的回答
知道答主
回答量:47
采纳率:0%
帮助的人:106万
展开全部
如果我输入a的是2^30 ,b是9,那会出现什么结果?
2^30*9>2^31~~溢出,那LZ明白了把?
那会改了把?
Xiinho
2011-04-23 · TA获得超过1279个赞
知道小有建树答主
回答量:776
采纳率:0%
帮助的人:755万
展开全部
//改成这样应该可以~
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,m;
while(cin>>a>>b)
{

int c=1;
a=a%10;
for(i=0;i<=(b-1)%4;i++)
{
c*=a
}
cout<<c%10<<endl;

}
return 0;
}
追问
我问我写的为什么不行???错误在哪??谢谢!!
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式