c++编程,注意,用c++(cin,cout)

c++编程,注意,用c++(cin,cout)DescriptionInthisproblem,yourtaskistocalculateSUM(n)=1+2+3+...... c++编程,注意,用c++(cin,cout)Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line. You can assume the result will be in the range of 32-bit signed integer.

Process to the end of file.

Sample Input
1
100

Sample Output
1
5050
展开
 我来答
好吊好长的名字
2016-12-01 · 超过10用户采纳过TA的回答
知道答主
回答量:22
采纳率:0%
帮助的人:15.2万
展开全部
#include <string>
#include <iostream>
#include <sstream>
using namespace std;

int sum(int max)
{
int result = 0;
for(int i = 1; i <= max; ++i)
result += i;
return result;
}

int main()
{
string line;
while(getline(cin,line))
{
int num;
stringstream ss(line);
ss >> num;
cout << sum(num) << endl;
}
return 0;
}

====================================
./a.out << EOF
> 1
> 100
> EOF
================================
1
5050
更多追问追答
追问
哥,不用这么复杂吧?
问一下输出的5050上边的那个1是怎么来的?
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式