编程高手赐教,,C语言,求x+y,x-y 。。。。
Description计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。Input输入只有一行,格式见sample。Output输出为...
Description
计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。
Input
输入只有一行,格式见sample。
Output
输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample
Sample Input
x = 11, y = 3
Sample Output
x + y : 14
x - y : 8
x * y : 33
x / y quotient: 3, remainder: 2
x ^ 2 : 121
y ^ 3 : 27
HINT
注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。
顺便帮我把程序写出来 展开
计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。
Input
输入只有一行,格式见sample。
Output
输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample
Sample Input
x = 11, y = 3
Sample Output
x + y : 14
x - y : 8
x * y : 33
x / y quotient: 3, remainder: 2
x ^ 2 : 121
y ^ 3 : 27
HINT
注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。
顺便帮我把程序写出来 展开
3个回答
展开全部
#include <stdio.h>
#include <stdlib.h>
int main( )
{
int x,y;
scanf("x = %d, y = %d",&x,&y);
printf("x + y : %d\n",x+y);
printf("x - y : %d\n",x-y);
printf("x * y : %d\n",x*y);
printf("x / y quotient: %d, remainder: %d\n",x/y,x%y);
printf("x ^ 2 : %d\n",x*x);
printf("y ^ 3 : %d\n",y*y*y);
//system("pause");/*要看是否准确就加*/
return 0;
}
我测过了,100%准确
#include <stdlib.h>
int main( )
{
int x,y;
scanf("x = %d, y = %d",&x,&y);
printf("x + y : %d\n",x+y);
printf("x - y : %d\n",x-y);
printf("x * y : %d\n",x*y);
printf("x / y quotient: %d, remainder: %d\n",x/y,x%y);
printf("x ^ 2 : %d\n",x*x);
printf("y ^ 3 : %d\n",y*y*y);
//system("pause");/*要看是否准确就加*/
return 0;
}
我测过了,100%准确
本回答被提问者采纳
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
2011-10-14
展开全部
123
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询