菜鸟级的acm题,兄弟们帮忙看下吧,调试正常,提交后就wrong了,谢了~
题目:输入一个字符串,判断其是否是C的合法标识符。Input输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超...
题目:
输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input
3
12ajf
fi8x_a
ff ai_2
Sample Output
no
yes
no
我的代码:
#include"stdio.h"
int main()
{
char str[60];
int n;
int i;
scanf("%d",&n);
while(n--)
{
getchar();
gets(str);
if(str[0]!='_'&&(str[0]<'A'||str[0]>'Z'&&str[0]<'a'||str[0]>'z'))
{
printf("no\n");
continue;
}
for(i=1;str[i]!='\0';i++)
{
if((str[i]<'0'||str[i]>'9'&&str[i]<'A'||str[i]>'Z'&&str[i]<'a'||str[i]>'z')&&str[i]!='_')
{
printf("no\n");
break;
}
}
if(str[i]=='\0')
printf("yes\n");
}
return 0;
} 展开
输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input
3
12ajf
fi8x_a
ff ai_2
Sample Output
no
yes
no
我的代码:
#include"stdio.h"
int main()
{
char str[60];
int n;
int i;
scanf("%d",&n);
while(n--)
{
getchar();
gets(str);
if(str[0]!='_'&&(str[0]<'A'||str[0]>'Z'&&str[0]<'a'||str[0]>'z'))
{
printf("no\n");
continue;
}
for(i=1;str[i]!='\0';i++)
{
if((str[i]<'0'||str[i]>'9'&&str[i]<'A'||str[i]>'Z'&&str[i]<'a'||str[i]>'z')&&str[i]!='_')
{
printf("no\n");
break;
}
}
if(str[i]=='\0')
printf("yes\n");
}
return 0;
} 展开
1个回答
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询