A+B for Input-Output Practice (VIII) 为什么 我在 杭电 上 做是 Presentation Error!

ProblemDescriptionYourtaskistocalculatethesumofsomeintegers.InputInputcontainsaninteg... Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

Author
lcy

Recommend
JGShining

#include<stdio.h>
int main( )
{
int a,b,i,j,m,n;
while(scanf("%d",&n)!=EOF)
{
for(j=0;j<n;j++)
{
b=0;
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d",&a);
b=b+a;
}
printf("%d\n\n",b);
}
}
return 0;
}
展开
 我来答
eboycheng
2012-02-16
知道答主
回答量:1
采纳率:0%
帮助的人:2.8万
展开全部
#include<stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int M,i,a,sum=0;
scanf("%d",&M);
for(i=0;i<M;i++)
{
scanf("%d",&a);
sum+=a;
}
if(N!=0)
printf("%d\n\n",sum);
else
printf("%d\n",sum);
}
}
最后的一行输出后没有空一格了。。。
祎童欣KO
2012-02-15
知道答主
回答量:37
采纳率:0%
帮助的人:23.5万
展开全部
\n少了一个好像
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式