ACM,本地运行正确,一提交就错误,怎么呢回事?
题目描述:第一行输入一个数n,1<=n<=1000,下面输入n行数据,每一行有两个数,分别是xy。输出一组xy,该组数据是所有数据中x最小,且在x相等的情况下y最小的。输...
题目描述:
第一行输入一个数n,1 <= n <= 1000,下面输入n行数据,每一行有两个数,分别是x y。输出一组x y,该组数据是所有数据中x最小,且在x相等的情况下y最小的。
输入:
输入有多组数据。
每组输入n,然后输入n个整数对。
输出:
输出最小的整数对。
样例输入:
5
3 3
2 2
5 5
2 1
3 6
样例输出:
2 1
我的代码:
import java.util.Scanner;
import java.util.TreeMap;
public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
int n = s.nextInt();
TreeMap<Integer,Integer> map = new TreeMap<Integer,Integer>();
for(int i=0; i<n; i++){
int key = s.nextInt();
int value = s.nextInt();
if(map.containsKey(key)){
if(value < map.get(key))
map.put(key, value);
}else
map.put(key, value);
}
int key = map.firstKey();
int value = map.get(key);
System.out.print(key + " ");
System.out.println(value);
}
} 展开
第一行输入一个数n,1 <= n <= 1000,下面输入n行数据,每一行有两个数,分别是x y。输出一组x y,该组数据是所有数据中x最小,且在x相等的情况下y最小的。
输入:
输入有多组数据。
每组输入n,然后输入n个整数对。
输出:
输出最小的整数对。
样例输入:
5
3 3
2 2
5 5
2 1
3 6
样例输出:
2 1
我的代码:
import java.util.Scanner;
import java.util.TreeMap;
public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
int n = s.nextInt();
TreeMap<Integer,Integer> map = new TreeMap<Integer,Integer>();
for(int i=0; i<n; i++){
int key = s.nextInt();
int value = s.nextInt();
if(map.containsKey(key)){
if(value < map.get(key))
map.put(key, value);
}else
map.put(key, value);
}
int key = map.firstKey();
int value = map.get(key);
System.out.print(key + " ");
System.out.println(value);
}
} 展开
1个回答
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询