输入一个以回车结束的字符串,将字符串中的字符按ASCII码从小到大顺序重组后输出。
Input输入一个以回车结束的字符串(少于80个字符)。Output将字符串中的字符按ASCII码从小到大顺序重组后输出SampleInputStudentSampleO...
Input
输入一个以回车结束的字符串(少于80个字符)。
Output
将字符串中的字符按ASCII码从小到大顺序重组后输出
Sample Input
Student
Sample Output
Sdenttu 展开
输入一个以回车结束的字符串(少于80个字符)。
Output
将字符串中的字符按ASCII码从小到大顺序重组后输出
Sample Input
Student
Sample Output
Sdenttu 展开
展开全部
上面人说用冒泡排序,我就写了个小程序,你看行不行
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1
{
class Program
{
public static void swap<T>(ref T a, ref T b)
{
T c;
c = a;
a = b;
b = c;
}
static void Main(string[] args)
{
//冒泡排序:
Console.WriteLine("请输入一个字符串");
char[] charArray = Console.ReadLine().ToCharArray();
Console.WriteLine();
Console.WriteLine("排序后:");
for (int i = 0; i < charArray.Length - 1; i++)
{
for (int j = i + 1; j < charArray.Length; j++)
{
if (charArray[i] > charArray[j])
{
swap<char>(ref charArray[i], ref charArray[j]);
}
}
}
string str = new string(charArray);
Console.WriteLine(str); //显示结果
}
}
}
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1
{
class Program
{
public static void swap<T>(ref T a, ref T b)
{
T c;
c = a;
a = b;
b = c;
}
static void Main(string[] args)
{
//冒泡排序:
Console.WriteLine("请输入一个字符串");
char[] charArray = Console.ReadLine().ToCharArray();
Console.WriteLine();
Console.WriteLine("排序后:");
for (int i = 0; i < charArray.Length - 1; i++)
{
for (int j = i + 1; j < charArray.Length; j++)
{
if (charArray[i] > charArray[j])
{
swap<char>(ref charArray[i], ref charArray[j]);
}
}
}
string str = new string(charArray);
Console.WriteLine(str); //显示结果
}
}
}
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询