指针 输入多个英文单词保存到字符串数组中,按照字母顺序从小到大输出。
输入多个英文单词保存到字符串数组中,按照字母顺序从小到大输出。要求:编写函数f(),对字符指针数组*s中的n个单词排序。输入多个英文单词(不超过100个),每行一个单词。...
输入多个英文单词保存到字符串数组中,按照字母顺序从小到大输出。
要求:编写函数f(),对字符指针数组*s中的n个单词排序。
输入
多个英文单词(不超过100个),每行一个单词。
输出
字母顺序从小到大显示。
样例输入
one
two
three
four
样例输出
four
one
three
two 展开
要求:编写函数f(),对字符指针数组*s中的n个单词排序。
输入
多个英文单词(不超过100个),每行一个单词。
输出
字母顺序从小到大显示。
样例输入
one
two
three
four
样例输出
four
one
three
two 展开
展开全部
#include<stdio.h>
#include<string.h>
#define LEN 100 //单词最大长度
#define NUM 5 //单词个数
int main()
{
char str[NUM][LEN];
int i = 0,j = 0;
for(i = 0;i < NUM;i++)
{
scanf("%s",str[i]); //输入单词
}
for(i = 1;i < NUM;i++) //对字符串排序
{
if(strcmp(str[i],str[i-1]) < 0)
{
char temp[NUM];
strcpy(temp,str[i]);
strcpy(str[i],str[i-1]);
for(j = i-2;strcmp(str[j],temp) > 0 && j >= 0;--j)
{
strcpy(str[j+1],str[j]);
}
strcpy(str[j+1],temp);
}
}
for(i = 0;i < NUM;i++)
{
printf("%s",str[i]);
printf("\n"); //输出单词
}
return 0;
}
#include<string.h>
#define LEN 100 //单词最大长度
#define NUM 5 //单词个数
int main()
{
char str[NUM][LEN];
int i = 0,j = 0;
for(i = 0;i < NUM;i++)
{
scanf("%s",str[i]); //输入单词
}
for(i = 1;i < NUM;i++) //对字符串排序
{
if(strcmp(str[i],str[i-1]) < 0)
{
char temp[NUM];
strcpy(temp,str[i]);
strcpy(str[i],str[i-1]);
for(j = i-2;strcmp(str[j],temp) > 0 && j >= 0;--j)
{
strcpy(str[j+1],str[j]);
}
strcpy(str[j+1],temp);
}
}
for(i = 0;i < NUM;i++)
{
printf("%s",str[i]);
printf("\n"); //输出单词
}
return 0;
}
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询