大神,请教一道C语言题目:调用自定义函数search(int list[], int n),在数组中查找某个数

Description输入10个整数存储到数组a,再输入一个整数x,在数组a中查找x,若找到则输出相应的下标,否则显示"Notfound"。要求定义和调用函数search... Description
输入10个整数存储到数组a,再输入一个整数x,在数组a中查找x,若找到则输出相应的下标,否则显示"Not found"。要求定义和调用函数search(int list[], int n, int x),在数组list中查找元素x,若找到则返回相应下标,否则返回-1.
Input
多组测试数据,每组先输入10个整数,再输入一个x
Output
输出x在数组中的下标或"Not found"
Sample Input
1 2 3 4 5 6 7 8 9 10 5
1 2 3 4 5 6 7 8 9 10 20

Sample Output
4
Not found

HINT
展开
 我来答
微俊king
推荐于2016-02-24 · TA获得超过576个赞
知道小有建树答主
回答量:626
采纳率:50%
帮助的人:558万
展开全部
#include<stdio.h>
#include<string.h>
#define N 20
int arr[N];


int search(int list[], int n, int x){

int i;
for(i = 1; i <= n; ++i)
if(list[i] == x)
return i;

return -1;
}

int main(){ 

int i, x, tmp;
while(1){
for(i = 1; i <= 10; ++i)
scanf("%d", arr+i);
scanf("%d", &x);

tmp = search(arr, N, x);
if(tmp > 0)
printf("%d\n", tmp - 1);
else
printf("Not found\n");
}
return 0;
}
更多追问追答
追问
运行起来是对的,但是交上去说“Running and  Jogging”
最终结果是Output Limit Exceed
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式