C语言问题,帮我看看我的代码哪里错了 北大ACM1003- Hangover
题目:DescriptionHowfarcanyoumakeastackofcardsoverhangatable?Ifyouhaveonecard,youcancrea...
题目:
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n+ 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input
1.00
3.71
0.04
5.19
0.00
Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)
我的C程序如下:
#include<stdio.h>
main()
{
int cards,i;
double longth,sum=0;
scanf("%lf",&longth);
while(cards!=0.00 && cards>=0.01 && cards<= 5.20){
cards=0,sum=0;
printf("longth=%lf\t",longth);
for(i = 2; sum <longth; i++) {
sum += 1.00/i;
cards++;}
printf("%d card(s)\n", cards);
scanf("%lf",&longth);}
return 0;
} 展开
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n+ 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input
1.00
3.71
0.04
5.19
0.00
Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)
我的C程序如下:
#include<stdio.h>
main()
{
int cards,i;
double longth,sum=0;
scanf("%lf",&longth);
while(cards!=0.00 && cards>=0.01 && cards<= 5.20){
cards=0,sum=0;
printf("longth=%lf\t",longth);
for(i = 2; sum <longth; i++) {
sum += 1.00/i;
cards++;}
printf("%d card(s)\n", cards);
scanf("%lf",&longth);}
return 0;
} 展开
2个回答
科博尔
2024-10-31 广告
2024-10-31 广告
上海科博尔铸件(集团)有限公司,是为空压泵体、机壳、床身、机床等其他机械行业配套生产灰铁、球铁铸件的专业生产厂家,并通过质量管理体系ISO 9001:2008。工厂座落于安徽宁国港口镇,位于浙江和江苏安徽三省交界处,位置和交通十分优越。企业...
点击进入详情页
本回答由科博尔提供
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询