ACM题目,数列问题

已知一个数列的前3个数为3,4,5,以后每个数为前3个数的和,编程序求此数列的第N项input:输入N(N<=35)output:求出第N项的值sampleinput:2... 已知一个数列的前3个数为3,4,5,以后每个数为前3个数的和,编程序求此数列的第N项

input : 输入N(N<=35)
output : 求出第N项的值
sample input : 28
sample output : 25527448
HINT
求解决下
展开
 我来答
百度网友28b4182
2013-04-24 · TA获得超过7218个赞
知道大有可为答主
回答量:4847
采纳率:100%
帮助的人:1773万
展开全部
#include <iostream>
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string>
#include <map>
#include <vector>
#include <stack>
#include <queue>
using namespace std;
int main(){
int f[36]={0,3,4,5};
int i,n;
for(i=4;i<36;i++)f[i]=f[i-1]+f[i-2]+f[i-3];
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",f[n]);
}
return 0;
}
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式