C++ ACM编程出现Runtime Error SIGSEGV错误,不知道到底出错在哪里啊?求高人指点

题目:ReducedIDNumbersT.ChurteachesvariousgroupsofstudentsatuniversityU.EveryU-studentha... 题目:
Reduced ID Numbers

T.Chur teaches various groups of students at university U. Every U-student has a unique
Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with
MaxSIN = 106-1. T.Chur finds this range of SINs too large for identification within her
groups. For each group, she wants to find the smallest positive integer m, such that within
the group all SINs reduced modulo m are unique.
Input

On the first line of the input is a single positive integer N, telling the number of test cases
(groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300):
the number of students in the group. The following G lines each contain one SIN. The SINs
within a group are distinct, though not necessarily sorted.
Output

For each test case, output one line containing the smallest modulus m, such that all SINs
reduced modulo m are distinct.
Sample Input
2
1
124866
3
124866
111111
987651

Sample Output
1
8

我的代码:
#include<iostream>
using namespace std;
int main()
{
int casenum,G;
long long SIN;
int m,i,j,k,p,temp;
long long a[310],b[10000];

cin>>casenum;
for(i=1;i<=casenum;i++)
{
cin>>G;

for(j=0;j<G;j++)
{
cin>>SIN;
a[j]=SIN;
}

temp=0;
for(j=0;j<G;j++)
{
for(k=j+1;k<G;k++)
{
b[temp]=a[j]-a[k];

if(b[temp<0])
b[temp]=-b[temp];

temp++;
}
}

for(m=1; ;m++)
{
p=1;
for(j=0;j<temp;j++)
{
if(b[j]%m==0 )
{
p=0;
break;
}
}

if(p==1)
{
cout<<m<<endl;
break;
}
}

}

//system("pause");
return 0;
}
展开
 我来答
将家是
2013-07-11 · TA获得超过309个赞
知道小有建树答主
回答量:296
采纳率:100%
帮助的人:170万
展开全部
我遇到过很多次这样的问题,一般都是数组越界
1、数组开小了,可以试着开大。空间会够的
2、在逻辑上不当,造成了越界的操作。

希望你能自己找到原因,这样对你自己也是一个提升
意法半导体(中国)投资有限公司
2023-06-12 广告
单片机,即单片微控制器,也称为单片微型计算机,是将中央处理器(CPU)、存储器(ROM,RAM)、输入/输出接口和其他功能部件集成在一块 在一个小块的集成电路上,从而实现对整个电路或系统的数字式控制。单片机不是完成某一个逻辑功能的芯片,而是... 点击进入详情页
本回答由意法半导体(中国)投资有限公司提供
Hiei1234
2013-07-11 · TA获得超过157个赞
知道小有建树答主
回答量:221
采纳率:0%
帮助的人:125万
展开全部
段错误原因太多了,自己一段段注释调试

找到段错误语句再分析 为什么出现
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式