一道简单的acm题,可是我老是通不过oj

InputInputcontainsmultipletestcases,andonecaseoneline.EachcasestartswithanintegerN,an... Input
Inputcontains multiple test cases, and one case one line. Each case starts with aninteger N, and then N integers follow in the same line.

Output
For each testcase you should output the sum of N integers in one line, and with one line ofoutput for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15
展开
 我来答
军天下wolfer
推荐于2016-09-09 · TA获得超过2081个赞
知道小有建树答主
回答量:734
采纳率:100%
帮助的人:930万
展开全部
#include<stdio.h>
 
int main()
{
    int n,x,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum = 0;
        while(n--)
        {
            scanf("%d",&x);
            sum+=x;
        }
        printf("%d/n",sum);
    }
    return 0;
}

学习一下输入输出就好,欢迎交流。

更多追问追答
追问
oj也报错,还有你的换行应该是\n
追答
给个题目网址吧,我试一下。
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式