Java中ACM问题!求解!
http://acm.bchine.com/problem.php?id=1023Descriptionwill要给心爱的姑娘买巧克力和鲜花,但是他只有N(N≤200)元...
http://acm.bchine.com/problem.php?id=1023
Description
will 要给心爱的姑娘买巧克力和鲜花,但是他只有 N(N ≤ 200)元钱。礼品店的老板有个习惯,那就是从来不找零,
也不讨价还价。现在鲜花a(a ≤ 200)元/朵,巧克力b(b ≤ 200)元/块。他不想让礼物太单调,所以礼物既要有鲜花,
又要有巧克力。请问 will 能否恰好用这N元给心爱的姑娘买礼物?
Input
多组测试数据,测试数据的第一行一个正整数t(t ≤ 100)表示有 t 组测试数据。每组测试数据只有一行,三个正整数
N a b,对应题目中的条件。数据不含多余的空行、空格。
Output
每组测试数据输出一行,如果 will 可以采用某种方案买礼物,输出"Yes",否则输出"No"。
Sample Input
2
3 1 2
5 2 2
Sample Output
Yes
No
我的代码:
import java.util.*;
public class Liwu {
public static void main(String[] args) {
boolean can =false;
Scanner scan = new Scanner(System.in);
int count = scan.nextInt();
for (int i = 0; i < count; i++) {
int money = scan.nextInt();
int a = scan.nextInt();
int b = scan.nextInt();
can = false;
for (int j = 1; j <= money / a; j++) {
int c = money - j * a;
if (c>0&&c % b == 0) {
can = true;
}
}
if (can)
System.out.println("YES");
else
System.out.println("NO");
}
}
}
提交后显示wrong answer ,请问是什么原因呢呢? 展开
Description
will 要给心爱的姑娘买巧克力和鲜花,但是他只有 N(N ≤ 200)元钱。礼品店的老板有个习惯,那就是从来不找零,
也不讨价还价。现在鲜花a(a ≤ 200)元/朵,巧克力b(b ≤ 200)元/块。他不想让礼物太单调,所以礼物既要有鲜花,
又要有巧克力。请问 will 能否恰好用这N元给心爱的姑娘买礼物?
Input
多组测试数据,测试数据的第一行一个正整数t(t ≤ 100)表示有 t 组测试数据。每组测试数据只有一行,三个正整数
N a b,对应题目中的条件。数据不含多余的空行、空格。
Output
每组测试数据输出一行,如果 will 可以采用某种方案买礼物,输出"Yes",否则输出"No"。
Sample Input
2
3 1 2
5 2 2
Sample Output
Yes
No
我的代码:
import java.util.*;
public class Liwu {
public static void main(String[] args) {
boolean can =false;
Scanner scan = new Scanner(System.in);
int count = scan.nextInt();
for (int i = 0; i < count; i++) {
int money = scan.nextInt();
int a = scan.nextInt();
int b = scan.nextInt();
can = false;
for (int j = 1; j <= money / a; j++) {
int c = money - j * a;
if (c>0&&c % b == 0) {
can = true;
}
}
if (can)
System.out.println("YES");
else
System.out.println("NO");
}
}
}
提交后显示wrong answer ,请问是什么原因呢呢? 展开
1个回答
展开全部
下面的是Accepted的代码:
import java.util.*;
public class Main{
public static void main(String[] args) {
boolean can =false;
Scanner scan = new Scanner(System.in);
int count = scan.nextInt();
for (int i = 0; i < count; i++) {
int money = scan.nextInt();
int a = scan.nextInt();
int b = scan.nextInt();
can = false;
for (int j = 1; j <= money / a; j++) {
int c = money - j * a;
if (c>0&&c % b == 0) {
can = true;
}
}
if (can)
System.out.println("Yes");
else
System.out.println("No");
}
}
}
追问
和我的有什么区别么?我的哪里错了?
追答
首先,类名要用Main,即
public class Main
第二,输出的是Yes和No,即只有第一个字母大写,后边的都是小写。
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询