C++ 大神来帮我改下这个程序
描述输入多个(不超过20个)学生的学号与分数,计算所有学生的平均分。要求:使用类的静态成员来计算。输入多个学生的学号与分数。输出所有学生的平均分(保留2位小数)。样例输入...
描述
输入多个(不超过20个)学生的学号与分数,计算所有学生的平均分。
要求:使用类的静态成员来计算。
输入
多个学生的学号与分数。
输出
所有学生的平均分(保留2位小数)。
样例输入
zhangsan 500
lisi 528
wangwu 546
zhaoliu 512
样例输出
521.50
代码如下
#include <iostream>
#include <iomanip>
using namespace std;
class student
{
public:
student(char n[],int s)
{
strcpy(name,n);
score=s;
total+=s;
count++;
}
static void disp()
{ cout<<fixed<<setprecision(2)<<1.0*total/count<<endl; }
private:
char name[20];
int score;
static int total,count;
};
int student::total=0;
int student::count=0;
int main()
{
char name[20];
int score;
while(cin>>name>>score)
{
student st(name,score);
}
student::disp();
system("pause");
return 0;
} 展开
输入多个(不超过20个)学生的学号与分数,计算所有学生的平均分。
要求:使用类的静态成员来计算。
输入
多个学生的学号与分数。
输出
所有学生的平均分(保留2位小数)。
样例输入
zhangsan 500
lisi 528
wangwu 546
zhaoliu 512
样例输出
521.50
代码如下
#include <iostream>
#include <iomanip>
using namespace std;
class student
{
public:
student(char n[],int s)
{
strcpy(name,n);
score=s;
total+=s;
count++;
}
static void disp()
{ cout<<fixed<<setprecision(2)<<1.0*total/count<<endl; }
private:
char name[20];
int score;
static int total,count;
};
int student::total=0;
int student::count=0;
int main()
{
char name[20];
int score;
while(cin>>name>>score)
{
student st(name,score);
}
student::disp();
system("pause");
return 0;
} 展开
1个回答
展开全部
就是加一个限制数量而已
#include <iostream>
#include <iomanip>
using namespace std;
class student
{
public:
student(char n[],int s)
{
strcpy(name,n);
score=s;
total+=s;
count++;
}
static void disp()
{ cout<<fixed<<setprecision(2)<<1.0*total/count<<endl; }
private:
char name[20];
int score;
static int total,count;
};
int student::total=0;
int student::count=0;
int main()
{
int i = 0;
char name[20];
int score;
while(cin>>name>>score && i<20)
{
student st(name,score);
i++;
}
student::disp();
system("pause");
return 0;
}
AiPPT
2024-09-19 广告
2024-09-19 广告
随着AI技术的飞速发展,如今市面上涌现了许多实用易操作的AI生成工具1、简介:AiPPT: 这款AI工具智能理解用户输入的主题,提供“AI智能生成”和“导入本地大纲”的选项,生成的PPT内容丰富多样,可自由编辑和添加元素,图表类型包括柱状图...
点击进入详情页
本回答由AiPPT提供
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询