这道java题应该怎么做?

编写坐标系的zhong的点类Cpoint。1、编写相应的构造方法初始化某个点;2、重载构造方法初始化对角线的点;3、编写重载方法计算点到原点,点到点,点到另一个坐标的距离... 编写坐标系的zhong 的点类Cpoint。1、编写相应的构造方法初始化某个点;2、重载构造方法初始化对角线的点;3、编写重载方法计算点到原点,点到点,点到另一个坐标的距离。
主函数如下:
public static void main(String[] args){
int x1,x,y1;
Scanner scn=new Scanner(System.in);
x1=scn.nextInt();y1=scn.nextInt();
x=scn.nextInt();
Point p1 = new Point(x1,y1);
Point p2 = new Point(x);
System.out.println(String.format("%.2f", p1.distance()));
System.out.println(String.format("%.2f", p2.distance()));
System.out.println(String.format("%.2f", p1.distance(6,8)));
System.out.println(String.format("%.2f", p1.distance(p2)));
}
输入

输入两个点
输出

点之间的距离
难度

一般
输入示例

3 4
5
输出示例

5.00
7.07
5.00
2.24
展开
 我来答
老冯文库
2020-04-08 · 知道合伙人软件行家
老冯文库
知道合伙人软件行家
采纳数:1139 获赞数:8733

向TA提问 私信TA
展开全部

Java源代码:

public class Test {

public static void main(String[] args) {

Point p1 = new Point(4, 5);

System.out.printf("点p坐标为(%f,%f)\n", p1.getX(), p1.getY());


p1.setX(3);

p1.setY(4);

System.out.printf("重置后点p坐标为(%f,%f)\n", p1.getX(), p1.getY());


System.out.printf("点(%f, %f)到原点的距离的平方为%f\n", p1.getX(), p1.getY(),

p1.distance());


Point p2 = new Point(1, 2);

System.out.printf("点(%f,%f)到点(%f,%f)的距离的平方为%f\n", p1.getX(),

p1.getY(), p2.getX(), p2.getY(), p1.distance(p2));

}

}


class Point {

protected double x;

protected double y;


public Point(){

}


public Point(double x, double y) {

this.x = x;

this.y = y;

}


public void setX(double x) {

this.x = x;

}


public double getX() {

return this.x;

}


public void setY(double y) {

this.y = y;

}


public double getY() {

return this.y;

}


public double distance() {

return Math.pow(x, 2) + Math.pow(y, 2);

}


public double distance(Point p) {

return Math.pow(this.x - p.x, 2) + Math.pow(this.y - p.y, 2);

}

}




运行测试:

杨政java
2020-03-06 · 超过24用户采纳过TA的回答
知道答主
回答量:107
采纳率:81%
帮助的人:20.5万
展开全部
public class Point {
private int x;
private int y;

public Point(int x, int y) {
this.x = x;
this.y = y;
}

public Point(int x) {
this(x, x);
}

public int getX() {
return x;
}

public int getY() {
return y;
}

public double distance(int x, int y) {
return Math.sqrt(Math.pow(x - this.x, 2) + Math.pow(y - this.y, 2));
}

public double distance(Point p) {
return distance(p.getX(), p.getY());
}

public double distance() {
return distance(0, 0);
}

public static void main(String[] args) {
int x1, x, y1;
Scanner scn = new Scanner(System.in);
x1 = scn.nextInt();
y1 = scn.nextInt();
x = scn.nextInt();
Point p1 = new Point(x1, y1);
Point p2 = new Point(x);
System.out.println(String.format("%.2f", p1.distance()));
System.out.println(String.format("%.2f", p2.distance()));
System.out.println(String.format("%.2f", p1.distance(6, 8)));
System.out.println(String.format("%.2f", p1.distance(p2)));
}
}
追问
谢谢,我已经会了
本回答被提问者和网友采纳
已赞过 已踩过<
你对这个回答的评价是?
评论 收起
收起 1条折叠回答
推荐律师服务: 若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询

为你推荐:

下载百度知道APP,抢鲜体验
使用百度知道APP,立即抢鲜体验。你的手机镜头里或许有别人想知道的答案。
扫描二维码下载
×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消

辅 助

模 式