ACM的Runtime Error疑问
#include<stdio.h>#include<malloc.h>typedefstructnode{intdata;node*next;}node;typedefs...
#include<stdio.h>
#include<malloc.h>
typedef struct node
{
int data;
node *next;
}node;
typedef struct vnode
{
char data;
node *next;
bool id;
}vnode;
int main()
{
int n,m;
char ch;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&m);
scanf("%c",&ch);
vnode *v=new vnode[m];
node *p,*temp;
p=(node *)malloc(sizeof(node)); //这个地方
for(int i1=1;i1<=m;i1++)
{
scanf("%c",&v[i1].data);
v[i1].id=false;
scanf("%c",&ch);
node *head;
head=(node *)malloc(sizeof(node));
head->data=0;
head->next=NULL;
p=head;
while(ch!='\n' && ch!=EOF)
{
temp=(node *)malloc(sizeof(node));
scanf("%d",&temp->data);
scanf("%c",&ch);
temp->next=NULL;
p->next=temp;
p=p->next;
}
v[i1].next=head->next;
}
for(int i2=1;i2<=m;i2++)
{
if(v[i2].next->data==0 && !v[i2].id)
{
printf("%c",v[i2].data);
v[i2].id=true;
for(p=v[i2].next->next;p!=NULL;p=p->next)
{
(v[p->data].next->data)--;
}
i2=0;
}
}
printf("\n");
}
}
这是拓扑排序的原程序,在这个程序里面注释出来的地方为什么如果p没有用malloc分配空间提交就会出现Runtime Erorr,而分配了空间就可以AC。
这是ACM的原题目:
数据输入:
第一行是一个整数N(1<=N<=20),表示有多少个图需要计算。以下每个图的第一行是整数M,表示此图有多少个顶点,以后的M行表示图的连接情况。表示连接情况的每行中首先是一个字符(字符为大写英文字符),表示节点名字,接着是一个整数K,表示有此顶点的入度,接着有K个整数,表示此顶点有到其他K个顶点的边。
数据输出:
每行输出一个例子的拓扑排序,为一个字符串。如果例子有多个顶点为0入度,以先出现的顶点为起始顶点。
Sample Input
2
3
A 0 2 3
B 1
C 1
4
A 0 2 4
B 2 4
C 0 2
D 2
Sample Output
ABC
ABDC 展开
#include<malloc.h>
typedef struct node
{
int data;
node *next;
}node;
typedef struct vnode
{
char data;
node *next;
bool id;
}vnode;
int main()
{
int n,m;
char ch;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&m);
scanf("%c",&ch);
vnode *v=new vnode[m];
node *p,*temp;
p=(node *)malloc(sizeof(node)); //这个地方
for(int i1=1;i1<=m;i1++)
{
scanf("%c",&v[i1].data);
v[i1].id=false;
scanf("%c",&ch);
node *head;
head=(node *)malloc(sizeof(node));
head->data=0;
head->next=NULL;
p=head;
while(ch!='\n' && ch!=EOF)
{
temp=(node *)malloc(sizeof(node));
scanf("%d",&temp->data);
scanf("%c",&ch);
temp->next=NULL;
p->next=temp;
p=p->next;
}
v[i1].next=head->next;
}
for(int i2=1;i2<=m;i2++)
{
if(v[i2].next->data==0 && !v[i2].id)
{
printf("%c",v[i2].data);
v[i2].id=true;
for(p=v[i2].next->next;p!=NULL;p=p->next)
{
(v[p->data].next->data)--;
}
i2=0;
}
}
printf("\n");
}
}
这是拓扑排序的原程序,在这个程序里面注释出来的地方为什么如果p没有用malloc分配空间提交就会出现Runtime Erorr,而分配了空间就可以AC。
这是ACM的原题目:
数据输入:
第一行是一个整数N(1<=N<=20),表示有多少个图需要计算。以下每个图的第一行是整数M,表示此图有多少个顶点,以后的M行表示图的连接情况。表示连接情况的每行中首先是一个字符(字符为大写英文字符),表示节点名字,接着是一个整数K,表示有此顶点的入度,接着有K个整数,表示此顶点有到其他K个顶点的边。
数据输出:
每行输出一个例子的拓扑排序,为一个字符串。如果例子有多个顶点为0入度,以先出现的顶点为起始顶点。
Sample Input
2
3
A 0 2 3
B 1
C 1
4
A 0 2 4
B 2 4
C 0 2
D 2
Sample Output
ABC
ABDC 展开
2个回答
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询