C语言判断一串字符是否为合法的标识符 我的怎么代码不对?
题目描述输入一个字符串,判断其是否是C的合法标识符。输入输入一个长度不超过50的字符串。输出如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。样例输入8...
题目描述
输入一个字符串,判断其是否是C的合法标识符。
输入
输入一个长度不超过50的字符串。
输出
如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
样例输入
8fixafghgjhjhjyuyuyyuyuyu
样例输出
no
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[1006];
int i,flag=1;
gets(str);
if(str[0]=='-'||isalpha(str[0]))
flag=1;
else
{
flag=0;goto IN;
}
for(i=1;str[i]!='\0';i++)
{
if(isdigit(str[i])||isalpha(str[i])||str[i]=='-')
flag=1;
else
{
flag=0;break;
}
}
if(flag==1)
printf("yes\n");
else
IN: printf("no\n");
return 0;
} 展开
输入一个字符串,判断其是否是C的合法标识符。
输入
输入一个长度不超过50的字符串。
输出
如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
样例输入
8fixafghgjhjhjyuyuyyuyuyu
样例输出
no
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[1006];
int i,flag=1;
gets(str);
if(str[0]=='-'||isalpha(str[0]))
flag=1;
else
{
flag=0;goto IN;
}
for(i=1;str[i]!='\0';i++)
{
if(isdigit(str[i])||isalpha(str[i])||str[i]=='-')
flag=1;
else
{
flag=0;break;
}
}
if(flag==1)
printf("yes\n");
else
IN: printf("no\n");
return 0;
} 展开
1个回答
展开全部
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[1006];
int i,flag=1;
gets(str);
if(str[0]=='_'||isalpha(str[0]))
flag=1;
else
{
flag=0;goto IN;
}
for(i=1;str[i]!='\0';i++)
{
if(isdigit(str[i])||isalpha(str[i])||str[i]=='_')
flag=1;
else
{
flag=0;break;
}
}
if(flag==1)
printf("yes\n");
else
IN: printf("no\n");
return 0;
}
已测试通过。把 ‘-’改成‘_’就好了
#include <ctype.h>
int main()
{
char str[1006];
int i,flag=1;
gets(str);
if(str[0]=='_'||isalpha(str[0]))
flag=1;
else
{
flag=0;goto IN;
}
for(i=1;str[i]!='\0';i++)
{
if(isdigit(str[i])||isalpha(str[i])||str[i]=='_')
flag=1;
else
{
flag=0;break;
}
}
if(flag==1)
printf("yes\n");
else
IN: printf("no\n");
return 0;
}
已测试通过。把 ‘-’改成‘_’就好了
追问
谢谢 呵呵 请问下划线在键盘怎么输入
追答
英文条件下,shift加-
求accept
本回答被提问者采纳
已赞过
已踩过<
评论
收起
你对这个回答的评价是?
推荐律师服务:
若未解决您的问题,请您详细描述您的问题,通过百度律临进行免费专业咨询
广告 您可能关注的内容 |